What’s Vulnerable › Vulnerabilities
CVE-2026-111910: phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta Authorization Bypass via attachment.php Downloads
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-21
- Weakness: CWE-862
Description
phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains an authorization bypass vulnerability in attachment.php that allows attackers to download attachments of restricted FAQs by bypassing per-record permission checks. Low-privileged users with the dlattachment right, or anonymous users when allowDownloadsForGuests is enabled, can request attachment IDs to retrieve confidential files from restricted FAQs.
Affected products
- thorsten phpMyFAQ: before 4.1.9; from 4.2.0-alpha before 4.2.0-beta — fixed in 4.1.9, 4.2.0-beta
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.9, 4.2.0-beta. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-pp67-9fv9-ph7q
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.9-and-4.2.0-alpha-before-4.2.0-beta-authorization-bypass-via-attachment-php-downloads
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-pp67-9fv9-ph7q
Get alerted when CVE-2026-111910 or the next vulnerability affects your stack