What’s Vulnerable › Vulnerabilities
CVE-2026-111915: Yank Note before 3.93.1 Path Traversal via /api/help Endpoint
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-19
- Weakness: CWE-22
Description
Yank Note before 3.93.1 contains a path traversal vulnerability that allows unauthenticated remote attackers to read arbitrary files via the path or doc parameter of /api/help. Attackers can supply repeated '../' segments, which bypass the single-replacement sanitization in the publicly allowlisted endpoint, to read SSH keys, configuration, or notes.
Affected products
- purocean Yank Note: before 3.93.1 — fixed in 3.93.1
How to fix
Upgrade to a fixed version: purocean Yank Note 3.93.1. Check the vendor advisory for mitigations.
References
- https://github.com/purocean/yn/blob/v3.93.0/src/main/server/index.ts
- https://github.com/purocean/yn/commit/d3b0ad27f7f6388b878eefd828557ae2d2a8789b
- https://github.com/purocean/yn/issues/543
- https://github.com/purocean/yn/releases/tag/v3.93.1
- https://www.vulncheck.com/advisories/yank-note-before-3.93.1-path-traversal-via-api-help-endpoint
Get alerted when CVE-2026-111915 or the next vulnerability affects your stack