What’s Vulnerable › Vulnerabilities
CVE-2026-111924: Fleet before 4.83.0 Denial of Service via Unbounded Gzip Decompression
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-19
- Weakness: CWE-409
Description
Fleet before 4.83.0 contains a denial of service vulnerability that allows unauthenticated attackers to exhaust server memory by sending gzip-compressed request bodies. Attackers can send small, highly compressed requests with Content-Encoding: gzip to unauthenticated endpoints that expand during decoding, crashing the entire Fleet instance.
Affected products
- fleetdm fleet: before 4.83.0 — fixed in 4.83.0
How to fix
Upgrade to a fixed version: fleetdm fleet 4.83.0. Check the vendor advisory for mitigations.
References
- https://github.com/fleetdm/fleet/security/advisories/GHSA-3982-g48v-9rwh
- https://www.vulncheck.com/advisories/fleet-before-4.83.0-denial-of-service-via-unbounded-gzip-decompression
Get alerted when CVE-2026-111924 or the next vulnerability affects your stack