What’s Vulnerable › Vulnerabilities
CVE-2026-111928: Coder 2.0.0 before 2.34.8 Authorization Bypass via User-Level ACL in RBAC Policy
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-19
- Weakness: CWE-863
Description
Coder from 2.0.0 before 2.34.8 contains an incorrect authorization vulnerability in the acl_allow rule of coderd/rbac/policy.rego, which does not verify organization membership for per-user ACL entries, and organization member removal does not scrub those entries. Authenticated users removed from an organization can keep accessing previously granted org-scoped resources such as templates and workspaces via the API.
Affected products
- coder: from 2.0.0 before 2.34.8 — fixed in 2.34.8
How to fix
Upgrade to a fixed version: coder 2.34.8. Check the vendor advisory for mitigations.
References
- https://github.com/coder/coder/security/advisories/GHSA-7v78-w67v-pm2g
- https://www.vulncheck.com/advisories/coder-2.0.0-before-2.34.8-authorization-bypass-via-user-level-acl-in-rbac-policy
Get alerted when CVE-2026-111928 or the next vulnerability affects your stack