What’s Vulnerable › Vulnerabilities
CVE-2026-112001: ProjectSend 2.0.0 before 2.7.0 Incorrect Authorization via Users API Token Abilities
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-19
- Weakness: CWE-863
Description
ProjectSend 2.0.0 before 2.7.0 contains an incorrect authorization vulnerability that allows restricted API token holders to change the token owner's credentials via PATCH /api/v1/users/{user}. Attackers with a token limited to manage_users and edit_users can set a new owner password, clear two-factor authentication, and sign in interactively with the owner's full role permissions.
Affected products
- ProjectSend: from 2.0.0 before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: ProjectSend 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/projectsend/projectsend/blob/v2.6.0/app/Modules/Identity/StaffAccounts.php#L153-L162
- https://github.com/projectsend/projectsend/commit/db65731c3ad28ac7f0d541c60cb65eb100958514
- https://github.com/projectsend/projectsend/releases/tag/v2.7.0
- https://github.com/projectsend/projectsend/security/advisories/GHSA-j5cp-r8pr-m5cr
- https://www.vulncheck.com/advisories/projectsend-2.0.0-before-2.7.0-incorrect-authorization-via-users-api-token-abilities
- https://github.com/projectsend/projectsend/security/advisories/GHSA-j5cp-r8pr-m5cr
Get alerted when CVE-2026-112001 or the next vulnerability affects your stack