What’s Vulnerable › Vulnerabilities
CVE-2026-112002: ProjectSend 2.5.0 before 2.7.0 Unverified Password Change via /settings/password
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-19
- Weakness: CWE-620
Description
ProjectSend 2.5.0 before 2.7.0 contains an unverified password change vulnerability in PasswordController::update() that lets sessions of Social-provisioned accounts set local passwords without the current password. Attackers holding a stolen session cookie can send PUT /settings/password to create a durable local password, enroll their own second factor, and persistently take over the account.
Affected products
- ProjectSend: from 2.5.0 before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: ProjectSend 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/projectsend/projectsend/blob/v2.6.0/app/Http/Controllers/Settings/PasswordController.php#L54-L90
- https://github.com/projectsend/projectsend/commit/717852ff6a99391dbd816a2bb0bb3f40cad70f72
- https://github.com/projectsend/projectsend/releases/tag/v2.7.0
- https://github.com/projectsend/projectsend/security/advisories/GHSA-4r8h-mwfm-f5f4
- https://www.vulncheck.com/advisories/projectsend-2.5.0-before-2.7.0-unverified-password-change-via-settings-password
Get alerted when CVE-2026-112002 or the next vulnerability affects your stack