What’s Vulnerable › Vulnerabilities
CVE-2026-112015: Omnigent 0.3.0 before 0.14.0 Path Traversal via Sub-Agent os_env.cwd
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-19
- Weakness: CWE-22
Description
Omnigent 0.3.0 before 0.14.0 contains a path traversal vulnerability that allows authenticated users to escape the workspace by setting os_env.cwd on nested sub-agents. Attackers can upload a bundle whose sub-agent uses an absolute or parent-traversing working directory, bypassing root-only validation in bundles.py, to read and write host files as the runner user.
Affected products
- omnigent-ai omnigent: from 0.3.0 before 0.14.0 — fixed in 0.14.0
How to fix
Upgrade to a fixed version: omnigent-ai omnigent 0.14.0. Check the vendor advisory for mitigations.
References
- https://github.com/omnigent-ai/omnigent/blob/v0.13.0/omnigent/server/bundles.py#L138-L155
- https://github.com/omnigent-ai/omnigent/commit/4a406d5b3b3f3a7c3401eab659ab04e728923b94
- https://github.com/omnigent-ai/omnigent/releases/tag/v0.14.0
- https://github.com/omnigent-ai/omnigent/security/advisories/GHSA-p5x3-3gqh-x44g
- https://www.vulncheck.com/advisories/omnigent-0.3.0-before-0.14.0-path-traversal-via-sub-agent-os-env-cwd
Get alerted when CVE-2026-112015 or the next vulnerability affects your stack