What’s Vulnerable › Vulnerabilities
CVE-2026-112021: snac2 before 2.93 Heap-Based Buffer Overflow via JSON Parser _xs_json_load_lexer()
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-19
- Weakness: CWE-122
Description
snac2 before 2.93 contains a heap-based buffer overflow vulnerability in _xs_json_load_lexer() that allows unauthenticated remote attackers to corrupt heap memory by sending JSON strings containing a \u0000 escape. Attackers can send a single crafted application/activity+json POST to activitypub_post_handler(), which parses it before signature checks, overflowing heap allocations and crashing the server.
Affected products
- grunfink snac2: before 2.93 — fixed in 2.93
How to fix
Upgrade to a fixed version: grunfink snac2 2.93. Check the vendor advisory for mitigations.
References
- https://codeberg.org/grunfink/snac2
- https://codeberg.org/grunfink/snac2/commit/ec2c5c2046e0381bc942ec5d0d05ec861fe377e7
- https://codeberg.org/grunfink/snac2/releases/tag/2.93
- https://codeberg.org/grunfink/snac2/src/tag/2.92/xs_json.h#L283-L285
- https://gist.github.com/nullenvk/2bf288e2d34cb3d4b7143e61dbf7d90b
- https://nullenvk.pl/posts/02-snac2-json
- https://www.vulncheck.com/advisories/snac2-before-2.93-heap-based-buffer-overflow-via-json-parser-xs-json-load-lexer
Get alerted when CVE-2026-112021 or the next vulnerability affects your stack