What’s Vulnerable › Vulnerabilities
CVE-2026-112085: webpack-dev-server vulnerable to cross-origin WebSocket access via proxied upgrades
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-29
- Weakness: CWE-346
Description
webpack-dev-server is a development server that provides live reloading for webpack projects. In versions before 5.2.7 and in version 6.0.0, when a proxy entry is configured to forward WebSockets, the server forwards non-HMR WebSocket upgrade requests to the proxy target without validating the Host or Origin headers, so the allowedHosts protection does not apply to those proxied upgrades. A malicious web page visited by a developer can open a cross-origin WebSocket through the dev server and read from and write to the proxied backend, even when the server is bound to loopback. The issue is fixed in webpack-dev-server 5.2.7 and 6.1.0, where proxied WebSocket upgrades pass the same Host and Origin validation as the HMR WebSocket, and users should upgrade to one of those versions or later. As a workaround, omit WebSocket forwarding from proxy entries that do not need it and scope the proxy to specific paths.
Affected products
- webpack-dev-server: before 5.2.7; from 6.0.0 before 6.1.0 — fixed in 5.2.7, 6.1.0
- webpack-dev-server: before 5.2.7; from 6.0.0 before 6.1.0 — fixed in 5.2.7, 6.1.0
How to fix
Upgrade to a fixed version: webpack-dev-server 5.2.7, 6.1.0; webpack-dev-server 5.2.7, 6.1.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/webpack/webpack-dev-server/security/advisories/GHSA-cfqc-fj3v-j925
Get alerted when CVE-2026-112085 or the next vulnerability affects your stack