What’s Vulnerable › Vulnerabilities
CVE-2026-112111
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-19
- Weakness: CWE-79
Description
The Bootstrap Shortcodes plugin for WordPress before 3.4.6 is vulnerable to stored XSS via the id attribute of the [bs_tcontent] shortcode. The bs_tcontent() shortcode handler in inc/bs_tabs.php emits the id attribute value into an unquoted HTML attribute. esc_attr() is applied, but it does not encode space characters, so a space in the supplied value terminates the attribute and any following text is parsed as additional HTML attributes, including JavaScript event handlers. This allows authenticated attackers with Contributor-level access and above to inject arbitrary web script that executes in the browser of any user who views the page and interacts with the injected element.
Affected products
- Bootstrap Shortcodes: before 3.4.6 — fixed in 3.4.6
How to fix
Upgrade to a fixed version: Bootstrap Shortcodes 3.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/TheWebShop/bootstrap-shortcodes/commit/c26659ccb6ddb871c7dee1b77cb81cad63e7a75b
- https://github.com/TheWebShop/bootstrap-shortcodes/releases/tag/3.4.6
- https://plugins.trac.wordpress.org/browser/bootstrap-shortcodes/tags/3.4.4/inc/bs_tabs.php#L84
- https://wordpress.org/plugins/bootstrap-shortcodes/
- https://wordpress.org/plugins/bootstrap-shortcodes/#developers
Get alerted when CVE-2026-112111 or the next vulnerability affects your stack