What’s Vulnerable › Vulnerabilities
CVE-2026-112148
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-20
- Weakness: CWE-79
Description
A vulnerability has been identified in LIFF SDK versions 2.20.0 through 2.31.0, where a DOM-based cross-site scripting (XSS) flaw allows an attacker to execute arbitrary JavaScript in the origin of an affected LIFF application's endpoint when a user opens a specially crafted URL in an external browser, potentially leading to disclosure of JavaScript-accessible authentication tokens or application data, or unauthorized actions using the user's session.
Affected products
- LY Corporation LIFF SDK: from 2.20.0 before 2.31.1 — fixed in 2.31.1
How to fix
Upgrade to a fixed version: LY Corporation LIFF SDK 2.31.1. Check the vendor advisory for mitigations.
References
- https://github.com/line/liff/security/advisories/GHSA-wppr-qmp4-w627
- https://line.github.io/security-advisory-blog/CVE-2026-112148/
Get alerted when CVE-2026-112148 or the next vulnerability affects your stack