What’s Vulnerable › Vulnerabilities
CVE-2026-112285: Thelia before 3.1.5 and 3.2.4 Coupon Usage Limit Bypass via Pay-Later Orders
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-19
- Weakness: CWE-837
Description
Thelia before 3.1.5 and 3.2.x before 3.2.4 contains a business logic vulnerability that allows authenticated customers to bypass coupon usage limits because usage is counted only when orders become paid. Attackers can place multiple pay-later orders while a usage remains, or cancel paid orders to inflate max_usage, gaining unlimited discounts.
Affected products
- Thelia: from 2.6.2 before 3.1.5; from 3.2.0 before 3.2.4 — fixed in 3.1.5, 3.2.4
How to fix
Upgrade to a fixed version: Thelia 3.1.5, 3.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/thelia/thelia/blob/3.2.3/core/lib/Thelia/Action/Coupon.php
- https://github.com/thelia/thelia/blob/3.2.3/core/lib/Thelia/Domain/Promotion/Coupon/Service/CouponManager.php
- https://github.com/thelia/thelia/blob/3.2.3/core/lib/Thelia/Domain/Promotion/Coupon/Service/OrderCouponUsageManager.php
- https://github.com/thelia/thelia/commit/1c3ed9c7ad57fec8ea959aa2d2f506f9892777ea
- https://github.com/thelia/thelia/commit/edb7078bfce5ea31b40868d340b0b49dcc6cf00c
- https://github.com/thelia/thelia/releases/tag/3.1.5
- https://github.com/thelia/thelia/releases/tag/3.2.4
- https://github.com/thelia/thelia/security/advisories/GHSA-pq5m-7g9w-ppg8
- https://www.vulncheck.com/advisories/thelia-before-3.1.5-and-3.2.4-coupon-usage-limit-bypass-via-pay-later-orders
Get alerted when CVE-2026-112285 or the next vulnerability affects your stack