What’s Vulnerable › Vulnerabilities

CVE-2026-112378: Use of Less Trusted Source in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.8 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that under certain conditions could have allowed an authenticated user to access paid AI features without a valid subscription due to insufficient server-side validation in billing eligibility checks.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.3.6, 19.4.3; GitLab 19.3.6, 19.4.3, 19.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-112378 or the next vulnerability affects your stack