What’s Vulnerable › Vulnerabilities
CVE-2026-112712: @fastify/middie vulnerable to path-scoped middleware bypass via scope prefix mismatch
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-30
- Weakness: CWE-436
Description
@fastify/middie is the Express-style middleware engine for Fastify. In versions from 9.0.0 through 9.3.5, the use() function joined a path-scoped middleware's mount path to the plugin scope prefix in a way that could diverge from the path Fastify's router serves, most often when the scope prefix ended in a slash, and also for array mount paths and for mount paths written without a leading slash. When the two paths disagreed, the middleware was silently skipped while the route handler still ran, so path-scoped middleware such as authentication, authorization, or rate limiting could be bypassed by a single unauthenticated request. The issue is fixed in @fastify/middie 9.3.6, and users should upgrade to 9.3.6 or later. As a workaround, enforce authorization in a Fastify hook such as preHandler that runs after the router has resolved the request.
Affected products
- @fastify/middie: from 9.0.0 before 9.3.6 — fixed in 9.3.6
How to fix
Upgrade to a fixed version: @fastify/middie 9.3.6. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/middie/security/advisories/GHSA-5p92-8765-9fv8
Get alerted when CVE-2026-112712 or the next vulnerability affects your stack