What’s Vulnerable › Vulnerabilities
CVE-2026-112768: Parse Server before 8.6.99 and 9.x before 9.10.3-alpha.2 Information Disclosure via User Update
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-19
- Weakness: CWE-863
Description
Parse Server before 8.6.99 and 9.0.0 before 9.10.3-alpha.2 evaluates checks against the target account during a user update before authorizing the caller, and reflects their outcome in the response. An unauthorized caller, with or without a session, can confirm guessed usernames or emails and, when passwordPolicy.maxPasswordHistory or doNotAllowUsername is set, guessed current or previous passwords, bypassing account lockout.
Affected products
- parse-community parse-server: from 9.0.0 before 9.10.3-alpha.2; before 8.6.99 — fixed in 8.6.99, 9.10.3-alpha.2
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.99, 9.10.3-alpha.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-p49q-9w65-f9p7
- https://www.vulncheck.com/advisories/parse-server-before-8.6.99-and-9-x-before-9.10.3-alpha.2-information-disclosure-via-user-update
Get alerted when CVE-2026-112768 or the next vulnerability affects your stack