What’s Vulnerable › Vulnerabilities
CVE-2026-112769: Parse Server before 8.6.98 and 9.x before 9.10.3-alpha.1 Session Class-Level Permission Bypass
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-20
- Weakness: CWE-863
Description
Parse Server before 8.6.98 and 9.0.0 before 9.10.3-alpha.1 does not enforce the create and addField class-level permissions of the _Session class when creating sessions. An authenticated user, or anyone holding that user's session token, can send POST requests to /sessions or /classes/_Session to create additional sessions for that user and add fields to _Session; these sessions are not revoked when the original session is logged out.
Affected products
- parse-community parse-server: from 9.0.0 before 9.10.3-alpha.1; before 8.6.98 — fixed in 8.6.98, 9.10.3-alpha.1
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.98, 9.10.3-alpha.1. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-gj37-5hg5-p729
- https://www.vulncheck.com/advisories/parse-server-before-8.6.98-and-9-x-before-9.10.3-alpha.1-session-class-level-permission-bypass
Get alerted when CVE-2026-112769 or the next vulnerability affects your stack