What’s Vulnerable › Vulnerabilities
CVE-2026-112770: Craft CMS before 4.18.8 and 5.11.0 Authenticated RCE via Twig group Filter Array-Callable
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-22
- Weakness: CWE-94
Description
Craft CMS 4.x before 4.18.8 and 5.x before 5.11.0 contains a remote code execution vulnerability in the Twig group filter, which invokes non-string arrow arguments as callables without the checkArrow guard used by other arrow-accepting filters. Authenticated control panel users can pass an array-callable such as FileHelper::writeToFile via element-select condition rules to write a webshell to the webroot and execute code as the web user.
Affected products
- craftcms cms: from 4.0.0 before 4.18.8; from 5.0.0 before 5.11.0 — fixed in 4.18.8, 5.11.0
How to fix
Upgrade to a fixed version: craftcms cms 4.18.8, 5.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/security/advisories/GHSA-xmwr-88vw-5ghh
- https://www.vulncheck.com/advisories/craft-cms-before-4.18.8-and-5.11.0-authenticated-rce-via-twig-group-filter-array-callable
Get alerted when CVE-2026-112770 or the next vulnerability affects your stack