What’s Vulnerable › Vulnerabilities
CVE-2026-112773: Craft CMS 5.0.0 before 5.11.0 RCE via Twig Sandbox Behavior Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-19
- Weakness: CWE-94
Description
Craft CMS from 5.0.0 before 5.11.0 contains a remote code execution vulnerability that allows authenticated Control Panel users to escape the Twig sandbox by passing uncleansed criteria to getNext, getPrev, or getOwners. Attackers can inject Yii "as" or "on" config keys to attach malicious event handlers that execute when the element query runs, achieving code execution as the web user.
Affected products
- craftcms cms: from 5.0.0 before 5.11.0 — fixed in 5.11.0
How to fix
Upgrade to a fixed version: craftcms cms 5.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/security/advisories/GHSA-wr79-9v6x-5rfq
- https://www.vulncheck.com/advisories/craft-cms-5.0.0-before-5.11.0-rce-via-twig-sandbox-behavior-injection
Get alerted when CVE-2026-112773 or the next vulnerability affects your stack