What’s Vulnerable › Vulnerabilities
CVE-2026-112775: Craft CMS 5.0.0 before 5.11.0 Verification Code Reuse via users/set-password
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-22
- Weakness: CWE-287
Description
Craft CMS from 5.0.0 before 5.11.0 contains an authentication bypass vulnerability that allows attackers to reuse verification codes because users/verify-email does not invalidate them for active users. Attackers who obtain a victim's emailed code can submit it to users/set-password after the victim verifies an email change, resetting the password and taking over the account.
Affected products
- craftcms cms: from 5.0.0 before 5.11.0 — fixed in 5.11.0
How to fix
Upgrade to a fixed version: craftcms cms 5.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/security/advisories/GHSA-xh42-494x-2xgv
- https://www.vulncheck.com/advisories/craft-cms-5.0.0-before-5.11.0-verification-code-reuse-via-users-set-password
Get alerted when CVE-2026-112775 or the next vulnerability affects your stack