What’s Vulnerable › Vulnerabilities
CVE-2026-112776: Craft CMS 5.0.0 before 5.11.0 GraphQL Site-Scope Bypass via Mutations
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-20
- Weakness: CWE-863
Description
Craft CMS from 5.0.0 before 5.11.0 contains an authorization bypass vulnerability that allows site-scoped GraphQL tokens to mutate other sites' content because requireAllowedSite() is not enforced. Attackers holding a site-A token can create entries in site B via supplied siteId and delete entries, categories, tags, and assets shared across sites.
Affected products
- craftcms cms: from 5.0.0 before 5.11.0 — fixed in 5.11.0
How to fix
Upgrade to a fixed version: craftcms cms 5.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/security/advisories/GHSA-7rr3-4jcm-x526
- https://www.vulncheck.com/advisories/craft-cms-5.0.0-before-5.11.0-graphql-site-scope-bypass-via-mutations
Get alerted when CVE-2026-112776 or the next vulnerability affects your stack