What’s Vulnerable › Vulnerabilities
CVE-2026-112779: Grav API Plugin before 1.0.42 Cache Exhaustion and Page Permission Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-20
- Weakness: CWE-770
Description
Grav API plugin (grav-plugin-api) 1.0.40 before 1.0.42 caches a full translation dictionary for every well-formed language code sent to the unauthenticated GET /api/v1/translations/{lang} endpoint, and 1.0.16 before 1.0.42 fails to check target and destination page rules in the sync and batch copy endpoints. Unauthenticated attackers can send small requests that each store about 560 KB to exhaust disk or APCu, while accounts with api.pages.write can overwrite translations or create pages that page-level rules deny.
Affected products
- getgrav grav-plugin-api: from 1.0.16 before 1.0.42 — fixed in 1.0.42
How to fix
Upgrade to a fixed version: getgrav grav-plugin-api 1.0.42. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-8pcm-97fc-4xwh
- https://www.vulncheck.com/advisories/grav-api-plugin-before-1.0.42-cache-exhaustion-and-page-permission-bypass
Get alerted when CVE-2026-112779 or the next vulnerability affects your stack