What’s Vulnerable › Vulnerabilities
CVE-2026-112781: Grav 2.0.0 before 2.2.2 Information Disclosure via Form config-*@ Directives
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-20
- Weakness: CWE-200
Description
Grav from 2.0.0 before 2.2.2 contains an information disclosure vulnerability that allows page editors to read protected configuration by adding config-*@ directives to page frontmatter forms. Attackers with page-edit permission can bypass the Twig sandbox config_denied_paths redaction to expose security.salt, plugin credentials, and Redis passwords to all visitors.
Affected products
- getgrav grav: from 2.0.0 before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: getgrav grav 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-8wwq-x3w5-fxmw
- https://www.vulncheck.com/advisories/grav-2.0.0-before-2.2.2-information-disclosure-via-form-config-directives
Get alerted when CVE-2026-112781 or the next vulnerability affects your stack