What’s Vulnerable › Vulnerabilities
CVE-2026-112782: Grav before 1.7.53.5 and 2.2.2 Image Pixel Limit Bypass Denial of Service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-20
- Weakness: CWE-400
Description
Grav 1.7.53 before 1.7.53.5 and 2.0.0-rc.8 before 2.2.2 contains a resource exhaustion vulnerability that allows anonymous visitors to bypass the system.images.max_pixels limit when system.images.url_actions is enabled. Attackers can send single-dimension or percentage forceResize, zoomCrop, or chained image actions to make GD allocate multi-gigabyte canvases, exhausting server memory and taking the site down.
Affected products
- getgrav grav: from 2.0.0-rc.8 before 2.2.2; from 1.7.53 before 1.7.53.5 — fixed in 1.7.53.5, 2.2.2
How to fix
Upgrade to a fixed version: getgrav grav 1.7.53.5, 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-8gr9-59p6-r488
- https://www.vulncheck.com/advisories/grav-before-1.7.53.5-and-2.2.2-image-pixel-limit-bypass-denial-of-service
Get alerted when CVE-2026-112782 or the next vulnerability affects your stack