What’s Vulnerable › Vulnerabilities
CVE-2026-112785: OpenCATS before 0.10.0 Missing Authorization in Saved-List AJAX Endpoints
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-20
- Weakness: CWE-862
Description
OpenCATS before 0.10.0 contains a missing authorization vulnerability that allows READ-level users to create, rename, delete, and populate saved lists via AJAX endpoints. Authenticated attackers can send requests to newList.php, editListName.php, deleteList.php, or addToLists.php with any savedListID to alter or delete any saved list site-wide.
Affected products
- OpenCATS: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: OpenCATS 0.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/opencats/OpenCATS/blob/5781f41814f09493c7ce05b9251b5e09c1aff0cd/modules/lists/ajax/addToLists.php
- https://github.com/opencats/OpenCATS/blob/5781f41814f09493c7ce05b9251b5e09c1aff0cd/modules/lists/ajax/deleteList.php
- https://github.com/opencats/OpenCATS/blob/5781f41814f09493c7ce05b9251b5e09c1aff0cd/modules/lists/ajax/editListName.php
- https://github.com/opencats/OpenCATS/blob/5781f41814f09493c7ce05b9251b5e09c1aff0cd/modules/lists/ajax/newList.php
- https://github.com/opencats/OpenCATS/commit/aa3b414c3672f5010ca26c44192aa8e72d3735bd
- https://github.com/opencats/OpenCATS/issues/720
- https://github.com/opencats/OpenCATS/releases/tag/v0.10.0
- https://www.vulncheck.com/advisories/opencats-before-0.10.0-missing-authorization-in-saved-list-ajax-endpoints
Get alerted when CVE-2026-112785 or the next vulnerability affects your stack