What’s Vulnerable › Vulnerabilities
CVE-2026-112816: Improper certificate validation in the HTTPS listener in LXD
- Severity: critical (CVSS 10.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-30 · updated 2026-10-31
- Weakness: CWE-295
Description
Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15, 5.0.11, 5.21.9, 6.10.1 allows an unauthenticated attacker to authenticate as any trusted client and gain full access to the cluster and managed virtual machines via a crafted certificate chain.
Summary
CVE-2026-112816 is a critical (CVSS 10) improper certificate validation flaw in the HTTPS listener of Canonical LXD versions 4.0.14, 5.0.10, 5.21.8, and 6.9. An unauthenticated attacker can use a crafted certificate chain to authenticate as any trusted client, gaining full access to the cluster and its managed virtual machines. No exploitation has been reported (not in CISA KEV, SSVC exploitation: none). Upgrade to LXD 4.0.15, 5.0.11, 5.21.9, or 6.10.1.
CVE-2026-112816 ثغرة حرجة (CVSS 10) في التحقق غير السليم من الشهادات في مستمع HTTPS في Canonical LXD بالإصدارات 4.0.14 و5.0.10 و5.21.8 و6.9. يستطيع مهاجم غير مصادَق عليه استخدام سلسلة شهادات مُصمَّمة للتحقق كهوية أي عميل موثوق والحصول على وصول كامل إلى العنقود والأجهزة الافتراضية المُدارة. لم يُبلَّغ عن أي استغلال فعلي (ليست في CISA KEV، وتقييم SSVC للاستغلال: لا شيء). يجب الترقية إلى LXD 4.0.15 أو 5.0.11 أو 5.21.9 أو 6.10.1.
Affected products
- Canonical LXD: from 4.0.14 before 4.0.15; from 5.0.10 before 5.0.11; from 5.21.8 before 5.21.9; from 6.9.0 before 6.10.1 — fixed in 4.0.15, 5.0.11, 5.21.9, 6.10.1
How to fix
Upgrade to a fixed version: Canonical LXD 4.0.15, 5.0.11, 5.21.9, 6.10.1. Check the vendor advisory for mitigations.
In the news
References
- https://discourse.ubuntu.com/t/lxd-4-0-15-lts-has-been-released/90571
- https://discourse.ubuntu.com/t/lxd-5-0-11-lts-has-been-released/90570/1
- https://discourse.ubuntu.com/t/lxd-5-21-9-lts-has-been-released/90565/1
- https://discourse.ubuntu.com/t/lxd-6-10-1-lts-has-been-released/90024
- https://discourse.ubuntu.com/t/security-advisory-critical-vulnerability-found-in-canonical-lxd-and-microcloud/90557
- https://github.com/canonical/lxd/security/advisories/GHSA-99jp-jwmc-65p4
Get alerted when CVE-2026-112816 or the next vulnerability affects your stack