What’s Vulnerable › Vulnerabilities
CVE-2026-113355: Chatwoot before 4.14.0 Stored XSS via Help Center Video Embed Links
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-20
- Weakness: CWE-79
Description
Chatwoot before 4.14.0 contains a stored cross-site scripting vulnerability that allows account administrators to inject JavaScript by crafting video-embed links in Help Center articles. Attackers can use angle-bracket link destinations with double quotes to break out of the unescaped iframe src attribute in render_embed_from_match, executing scripts for public visitors and stealing cw_conversation widget tokens.
Affected products
- chatwoot/chatwoot: before 4.14.0 — fixed in 4.14.0
How to fix
Upgrade to a fixed version: chatwoot/chatwoot 4.14.0. Check the vendor advisory for mitigations.
References
- https://github.com/chatwoot/chatwoot/blob/88ffa329eb6e18ae06b608d8b4bab96c0e1b8f44/lib/custom_markdown_renderer.rb#L75-L84
- https://github.com/chatwoot/chatwoot/commit/2192af80f405c70e3021191ff8b3f7e539c35e9d
- https://github.com/chatwoot/chatwoot/pull/14140
- https://github.com/chatwoot/chatwoot/releases/tag/v4.14.0
- https://www.vulncheck.com/advisories/chatwoot-before-4.14.0-stored-xss-via-help-center-video-embed-links
Get alerted when CVE-2026-113355 or the next vulnerability affects your stack