What’s Vulnerable › Vulnerabilities
CVE-2026-113493: GeoDirectory < 2.8.194 - Contributor+ Stored XSS via gd_map Shortcode width Attribute
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-24 · updated 2026-10-26
- Weakness: CWE-79
Description
The GeoDirectory WordPress plugin before 2.8.194 does not sanitise and escape some of its map shortcode attributes before outputting them within a style attribute, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks that execute in the context of any user viewing the affected content.
Affected products
- paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory: before 2.8.194 — fixed in 2.8.194
How to fix
Upgrade to a fixed version: paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory 2.8.194. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-113493 or the next vulnerability affects your stack