What’s Vulnerable › Vulnerabilities
CVE-2026-113500: LiteSpeed Cache < 7.9.2 - Unauthenticated Stored XSS via Font Display Optimization
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-23 · updated 2026-10-23
- Weakness: CWE-79
Description
The LiteSpeed Cache WordPress plugin before 7.9.2 does not limit one of its HTML optimization routines to stylesheet content, so it can delete the markup that closes an attribute in the rendered page, and combined with unescaped comment author output this allows unauthenticated users whose comments are published to inject event-handler attributes that run JavaScript in the browser of any visitor, including a logged-in administrator, viewing front-end pages while the optimization is enabled.
Affected products
- LiteSpeed Technologies LiteSpeed Cache: before 7.9.2 — fixed in 7.9.2
How to fix
Upgrade to a fixed version: LiteSpeed Technologies LiteSpeed Cache 7.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-113500 or the next vulnerability affects your stack