What’s Vulnerable › Vulnerabilities
CVE-2026-113607: Configurable Reports block for Moodle before 5.3.0 Authorization Bypass via get_report_data
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-20
- Weakness: CWE-863
Description
Configurable Reports block for Moodle before 5.3.0 contains an authorization bypass vulnerability that allows authenticated users to read restricted reports through the block_configurable_reports_get_report_data web service. When check_permissions fails, the function only adds a warning and still returns the full report table, letting any logged-in user supply arbitrary report ids to read SQL reports over user and grade data.
Affected products
- jleyva moodle-block_configurablereports: before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: jleyva moodle-block_configurablereports 5.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/jleyva/moodle-block_configurablereports/blob/5.2.0/classes/external.php#L95-L99
- https://github.com/jleyva/moodle-block_configurablereports/commit/4a0e6eadf7bdb6fa52ef71141bdf120cd68e6abc
- https://github.com/jleyva/moodle-block_configurablereports/releases/tag/5.3.0
- https://www.vulncheck.com/advisories/configurable-reports-block-for-moodle-before-5.3.0-authorization-bypass-via-get-report-data
Get alerted when CVE-2026-113607 or the next vulnerability affects your stack