What’s Vulnerable › Vulnerabilities
CVE-2026-113613: FlexGet before 3.20.7 Path Traversal (Zip Slip) via decompress plugin
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-21
- Weakness: CWE-22
Description
FlexGet before 3.20.7 contains a path traversal vulnerability in the decompress plugin that allows remote attackers to write arbitrary files by supplying malicious archive member paths. Attackers can deliver zip or rar archives with ../ sequences or absolute paths through a feed, writing Python files into the plugins directory for code execution.
Affected products
- FlexGet: before 3.20.7 — fixed in 3.20.7
How to fix
Upgrade to a fixed version: FlexGet 3.20.7. Check the vendor advisory for mitigations.
References
- https://github.com/Flexget/Flexget/blob/v3.20.6/flexget/components/archives/decompress.py#L74-L77
- https://github.com/Flexget/Flexget/commit/38fa748461e20befee942f5c79d8a098edea5c1f
- https://github.com/Flexget/Flexget/releases/tag/v3.20.7
- https://github.com/Flexget/Flexget/security/advisories/GHSA-6v57-v478-59v9
- https://www.vulncheck.com/advisories/flexget-before-3.20.7-path-traversal-zip-slip-via-decompress-plugin
Get alerted when CVE-2026-113613 or the next vulnerability affects your stack