What’s Vulnerable › Vulnerabilities
CVE-2026-113677: Froxlor 0.10.0 before 2.3.15 Missing Authorization via SubDomains.delete API
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-20
- Weakness: CWE-862
Description
Froxlor from 0.10.0 before 2.3.15 contains a missing authorization vulnerability in the SubDomains.delete API command that allows authenticated customers to delete reseller-provisioned main domains by supplying a main domain id. Attackers can bypass the web UI restriction to remove domains, orphan vhost, DNS and subdomain records, and drive subdomains_used below zero to gain extra subdomain allowance.
Affected products
- froxlor: from 0.10.0 before 2.3.15 — fixed in 2.3.15
How to fix
Upgrade to a fixed version: froxlor 2.3.15. Check the vendor advisory for mitigations.
References
- https://github.com/froxlor/froxlor/blob/2.3.14/lib/Froxlor/Api/Commands/SubDomains.php#L1161-L1211
- https://github.com/froxlor/froxlor/commit/078e3f4ba0429390b27baae6aa1cc5d8c9a80010
- https://github.com/froxlor/froxlor/releases/tag/2.3.15
- https://github.com/froxlor/froxlor/security/advisories/GHSA-pp2f-frcg-w8rv
- https://www.vulncheck.com/advisories/froxlor-0.10.0-before-2.3.15-missing-authorization-via-subdomains-delete-api
- https://github.com/froxlor/froxlor/security/advisories/GHSA-pp2f-frcg-w8rv
Get alerted when CVE-2026-113677 or the next vulnerability affects your stack