What’s Vulnerable › Vulnerabilities
CVE-2026-11371: BetterDocs < 4.5.5 - Unauthenticated Stored XSS via AI Doc Summarizer Prompt Injection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-16 · updated 2026-07-16
- Weakness: CWE-79
Description
The BetterDocs WordPress plugin before 4.5.5 does not sanitise an AI-generated documentation summary before storing and outputting it, and the feature that generates it is exposed to unauthenticated users, allowing them to store a malicious payload via prompt injection that executes in the browser of any visitor who views the affected page, including administrators.
Affected products
- BetterDocs: from 4.0.0 before 4.5.5 — fixed in 4.5.5
How to fix
Upgrade to a fixed version: BetterDocs 4.5.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-11371 or the next vulnerability affects your stack