What’s Vulnerable › Vulnerabilities
CVE-2026-113718: virtualenv: Xonsh activation literals depend on the script decoding codec
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-27
- Weakness: CWE-94
Description
virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, POSIX xonsh activation quote() uses repr() to write printable non-ASCII prompt or destination data into UTF-8 activate.xsh, while xonsh can read that script using $XONSH_ENCODING. Under a legacy multibyte codec such as GBK or Big5, a UTF-8 trail byte can consume the backslash before an adjacent quote, allowing the literal to close and attacker-influenced statements to execute when the user sources the generated script. This issue is fixed in version 21.14.9.
Affected products
- Pypi Virtualenv: before 21.14.9; 0.8, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9 (+298) — fixed in 21.14.9
- pypa virtualenv: before 21.14.9
How to fix
Upgrade to a fixed version: Pypi Virtualenv 21.14.9. Check the vendor advisory for mitigations.
References
- https://github.com/pypa/virtualenv/commit/e5fc2e6e189a877ff559af288919e3525d13e5e0
- https://github.com/pypa/virtualenv/pull/3432
- https://github.com/pypa/virtualenv/releases/tag/21.14.9
- https://github.com/pypa/virtualenv/security/advisories/GHSA-394h-qwmc-48pf
- https://github.com/pypa/virtualenv/security/advisories/GHSA-394h-qwmc-48pf
Get alerted when CVE-2026-113718 or the next vulnerability affects your stack