What’s Vulnerable › Vulnerabilities
CVE-2026-113722: virtualenv: Generated POSIX console launchers interpret destination paths as shell syntax
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-23
- Weakness: CWE-78
Description
virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, virtualenv's ScriptMakerCustom and pip pass an incompletely quoted interpreter path to distlib ScriptMaker when generating POSIX console scripts. When the path contains a space or produces a shebang longer than 127 bytes, distlib emits a /bin/sh wrapper whose double-quoted interpreter path still expands command substitutions and backticks. An attacker who influences the environment destination can therefore execute commands with the user's privileges when the user later runs a generated launcher; environment creation and activation do not trigger the command. Existing launchers are not repaired by upgrading virtualenv alone and must be regenerated, while a later independent pip installation or upgrade can reintroduce an affected launcher because pip's vendored distlib is unchanged. The virtualenv fix is released in version 21.14.9.
Affected products
- Pypi Virtualenv: before 21.14.9; 0.8, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9 (+298) — fixed in 21.14.9
- pypa virtualenv: before 21.14.9
How to fix
Upgrade to a fixed version: Pypi Virtualenv 21.14.9. Check the vendor advisory for mitigations.
References
- https://github.com/pypa/virtualenv/commit/2519941bed33ee0d3ac99277f67913e439e476a9
- https://github.com/pypa/virtualenv/pull/3417
- https://github.com/pypa/virtualenv/releases/tag/21.14.9
- https://github.com/pypa/virtualenv/security/advisories/GHSA-c978-59m8-c77v
- https://github.com/pypa/virtualenv/security/advisories/GHSA-c978-59m8-c77v
Get alerted when CVE-2026-113722 or the next vulnerability affects your stack