What’s Vulnerable › Vulnerabilities
CVE-2026-113723: virtualenv: Bash prompt values can change meaning under older compatibility modes
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-27
- Weakness: CWE-78
Description
virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, caller-supplied prompt text can become executable syntax in the bash activation prompt. An attacker must influence the value passed to virtualenv, and a user must subsequently activate the environment and draw the prompt. This vulnerability is fixed in 21.14.9.
Affected products
- Pypi Virtualenv: before 21.14.9; 0.8, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9 (+298) — fixed in 21.14.9
- pypa virtualenv: before 21.14.9
How to fix
Upgrade to a fixed version: Pypi Virtualenv 21.14.9. Check the vendor advisory for mitigations.
References
- https://github.com/pypa/virtualenv/commit/5f48d711731311428aebfae61d46957762155b22
- https://github.com/pypa/virtualenv/pull/3418
- https://github.com/pypa/virtualenv/releases/tag/21.14.9
- https://github.com/pypa/virtualenv/security/advisories/GHSA-6w3r-xr62-4xcp
- https://github.com/pypa/virtualenv/security/advisories/GHSA-6w3r-xr62-4xcp
Get alerted when CVE-2026-113723 or the next vulnerability affects your stack