What’s Vulnerable › Vulnerabilities
CVE-2026-11379: Incorrect Authorization in GitLab
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-06-26
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 13.11 prior to 18.11.6, 19.0 prior to 19.0.3, and 19.1 prior to 19.1.1 in which incorrect authorization in DAST site profile management could allow a user with Developer role to exfiltrate DAST site profile secrets under certain conditions.
Affected products
- GitLab: from 13.11.0 before 18.11.6; from 19.0.0 before 19.0.3; 19.1.0 — fixed in 18.11.6, 19.0.3
How to fix
Upgrade to a fixed version: GitLab 18.11.6, 19.0.3. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-1-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/517659
Get alerted when CVE-2026-11379 or the next vulnerability affects your stack