What’s Vulnerable › Vulnerabilities
CVE-2026-11386: ubuntu-pro-client Input Validation Vulnerability Leading to Arbitrary APT Directive Injection and Remote Code Execution
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-16 · updated 2026-07-16
- Weakness: CWE-20
Description
An input validation and injection vulnerability exists in Canonical ubuntu-pro-client (formerly ubuntu-advantage-tools). The client constructs APT source files (such as /etc/apt/sources.list.d/ubuntu-.list or their DEB822 equivalents) using data received directly from the contract server response via the directives.suites[] and directives.aptURL fields. Because the client utilizes Python's str.format() to write these files without performing escaping, validation, or newline character filtering, a malicious or tampered contract response containing embedded newline (\n) characters can successfully inject arbitrary, attacker-controlled deb configuration lines into root-owned APT sources. When combined with the unvalidated additionalPackages[] field—which is passed positionally into a root-executed apt-get install command—an attacker capable of spoofing or manipulating the contract response (e.g., via a compromised internal infrastructure, an intercepted connection utilizing a trusted CA, or local logical bugs) can force the client to fetch and install malicious packages. This ultimately leads to arbitrary code execution with root privileges on the affected system. This component is preinstalled on supported Ubuntu Server releases and auto-attaches by default on cloud provider Ubuntu Pro images.
Affected products
- Canonical ubuntu-pro-client (ubuntu-advantage-tools): before 37.3 — fixed in 37.3
- Canonical Ubuntu 14.04 LTS: all versions
- Canonical Ubuntu 16.04 LTS: all versions
- Canonical Ubuntu 18.04 LTS: all versions
- Canonical Ubuntu 20.04 LTS: all versions
- Canonical Ubuntu 22.04 LTS: all versions
- Canonical Ubuntu 24.04 LTS: all versions
- Canonical Ubuntu 26.04 LTS: all versions
How to fix
Upgrade to a fixed version: Canonical ubuntu-pro-client (ubuntu-advantage-tools) 37.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-11386 or the next vulnerability affects your stack