What’s Vulnerable › Vulnerabilities
CVE-2026-11400: Privilege Escalation in AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-05 · updated 2026-10-26
- Weakness: CWE-426
Description
An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL will allow a remote authenticated low-privilege actor to escalate privileges to those of another Amazon RDS user, including rds_superuser, via a crafted function created by the actor that runs when that user connects to the cluster through an affected wrapper. To remediate this issue, users should upgrade to AWS Advanced JDBC Wrapper version 4.0.1.
Affected products
- AWS Advanced JDBC Wrapper: from 3.0.0 before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: AWS Advanced JDBC Wrapper 4.0.1. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-039-aws/
- https://github.com/aws/aws-advanced-jdbc-wrapper/releases/tag/4.0.1
- https://github.com/aws/aws-advanced-jdbc-wrapper/security/advisories/GHSA-mhww-p97m-3368
Get alerted when CVE-2026-11400 or the next vulnerability affects your stack