What’s Vulnerable › Vulnerabilities
CVE-2026-114047: FreeRDP 2.0.0 before 3.32.0 Proxy Improper TLS Certificate Validation
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-22
- Weakness: CWE-295
Description
FreeRDP from 2.0.0 before 3.32.0 contains an improper certificate validation vulnerability in its proxy that accepts untrusted target TLS certificates when no verification module is configured. Network-positioned attackers can intercept the proxy's outbound connection and present a self-signed, wrong-hostname certificate to impersonate the RDP target and receive proxied session data.
Affected products
- FreeRDP: from 2.0.0 before 3.32.0 — fixed in 3.32.0
How to fix
Upgrade to a fixed version: FreeRDP 3.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-pjxv-5j98-cqx4
- https://www.vulncheck.com/advisories/freerdp-2.0.0-before-3.32.0-proxy-improper-tls-certificate-validation
Get alerted when CVE-2026-114047 or the next vulnerability affects your stack