What’s Vulnerable › Vulnerabilities
CVE-2026-114049: vLLM before 0.31.0 Stale allowed_token_ids Mask via InputBatch.condense
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-440
Description
vLLM before 0.31.0 contains a cross-request mask leak in InputBatch.condense() that allows remote attackers to constrain other clients' outputs by leaving stale allowed_token_ids rows. Attackers can submit concurrent constrained generate requests, including via unauthenticated /invocations, so recycled batch slots apply their token allowlist to victims' unrestricted requests.
Affected products
- vllm-project vllm: before 0.31.0 — fixed in 0.31.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-6cxc-2vcg-w5qc
- https://www.vulncheck.com/advisories/vllm-before-0.31.0-stale-allowed-token-ids-mask-via-inputbatch-condense
Get alerted when CVE-2026-114049 or the next vulnerability affects your stack