What’s Vulnerable › Vulnerabilities
CVE-2026-114051: vLLM before 0.31.0 Denial of Service via min_tokens in /inference/v1/generate
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-248
Description
vLLM before 0.31.0 skips the min_tokens <= max_tokens check for /inference/v1/generate requests with a null max_tokens, so the EngineCore input thread later dies on an uncaught VLLMValidationError while /health still returns 200. Unauthenticated remote attackers can send one request with an oversized min_tokens to hang all subsequent generation requests until manual restart.
Affected products
- vllm-project vllm: before 0.31.0 — fixed in 0.31.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-4xqp-c3mv-qff7
- https://www.vulncheck.com/advisories/vllm-before-0.31.0-denial-of-service-via-min-tokens-in-inference-v1-generate
Get alerted when CVE-2026-114051 or the next vulnerability affects your stack