What’s Vulnerable › Vulnerabilities
CVE-2026-114053: vLLM 0.7.3 before 0.31.0 RCE via mm_processor_kwargs.code_revision
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-27
- Weakness: CWE-94
Description
vLLM from 0.7.3 before 0.31.0 forwards the request-supplied mm_processor_kwargs.code_revision to Transformers AutoProcessor.from_pretrained, letting clients select which revision of a model's dynamic processor code is imported when trust_remote_code is enabled. An attacker controlling a revision in the served model repository can send a multimodal request to the unauthenticated /tokenize endpoint to execute arbitrary Python in the vLLM API process.
Affected products
- vllm-project vllm: from 0.7.3 before 0.31.0 — fixed in 0.31.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/570735520942b6428ae98f1eb442c6d88adae55e
- https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-6mm3-gc2m
- https://www.vulncheck.com/advisories/vllm-0.7.3-before-0.31.0-rce-via-mm-processor-kwargs-code-revision
Get alerted when CVE-2026-114053 or the next vulnerability affects your stack