What’s Vulnerable › Vulnerabilities
CVE-2026-114059: ArcadeDB before 26.10.1 RCE via Gremlin Groovy Engine Missing Authorization
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-863
Description
ArcadeDB before 26.10.1 contains a remote code execution vulnerability that allows authenticated users, including read-only reader role holders, to execute Groovy code because GremlinQueryEngine.command() lacks scripting authorization checks. Attackers can submit Gremlin commands to the POST /api/v1/command/{database} endpoint when the Groovy engine is enabled to run OS commands as the server process user.
Affected products
- ArcadeData arcadedb: before 26.10.1 — fixed in 26.10.1
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.10.1. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-h2j4-28h8-cj5v
- https://www.vulncheck.com/advisories/arcadedb-before-26.10.1-rce-via-gremlin-groovy-engine-missing-authorization
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-h2j4-28h8-cj5v
Get alerted when CVE-2026-114059 or the next vulnerability affects your stack