What’s Vulnerable › Vulnerabilities
CVE-2026-114065: Trigger.dev before 4.7.3 Tenant Filtering Bypass via Query Table Placeholders
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-21
- Weakness: CWE-89
Description
Trigger.dev before 4.7.3 contains a tenant filtering bypass vulnerability that allows authenticated users to read other tenants' data by using placeholder table syntax in POST /api/v1/query. Attackers can submit queries with FROM {database.table} expressions, including within subqueries, to skip table allowlist and tenant filters and expose run metadata and payloads.
Affected products
- triggerdotdev trigger.dev: before 4.7.3 — fixed in 4.7.3
How to fix
Upgrade to a fixed version: triggerdotdev trigger.dev 4.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-m79r-84cc-xwg9
- https://www.vulncheck.com/advisories/trigger-dev-before-4.7.3-tenant-filtering-bypass-via-query-table-placeholders
Get alerted when CVE-2026-114065 or the next vulnerability affects your stack