What’s Vulnerable › Vulnerabilities
CVE-2026-114067: Trigger.dev 4.5.0 before 4.6.2 Improper Authorization via snapshot-url Session Route
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-22
- Weakness: CWE-863
Description
Trigger.dev 4.5.0 before 4.6.2 contains an improper authorization vulnerability in the PUT snapshot-url session endpoint that allows public session token holders to obtain presigned S3 write URLs. End users can overwrite their own session's durable chat snapshot to forge the agent's conversation history, since the route lacks a secret-key-only check.
Affected products
- triggerdotdev trigger.dev: from 4.5.0 before 4.6.2 — fixed in 4.6.2
How to fix
Upgrade to a fixed version: triggerdotdev trigger.dev 4.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-pc95-gc74-wg87
- https://www.vulncheck.com/advisories/trigger-dev-4.5.0-before-4.6.2-improper-authorization-via-snapshot-url-session-route
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-pc95-gc74-wg87
Get alerted when CVE-2026-114067 or the next vulnerability affects your stack