What’s Vulnerable › Vulnerabilities
CVE-2026-114074: Trigger.dev before 4.5.10 Webhook SSRF Protection Bypass via 198.18.0.0/15 Range
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-918
Description
Trigger.dev before 4.5.10 contains a server-side request forgery vulnerability that allows authenticated project members to bypass webhook SSRF protections by targeting the non-global 198.18.0.0/15 benchmarking range. Attackers can configure alert-channel webhooks pointing at internally routed services in this range, which isUnsafeIPv4 omits, to perform blind internal probing and limited state-changing POST requests.
Affected products
- triggerdotdev trigger.dev: before 4.5.10 — fixed in 4.5.10
How to fix
Upgrade to a fixed version: triggerdotdev trigger.dev 4.5.10. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-fhh4-xvj5-m7pq
- https://www.vulncheck.com/advisories/trigger-dev-before-4.5.10-webhook-ssrf-protection-bypass-via-198.18.0.0-15-range
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-fhh4-xvj5-m7pq
Get alerted when CVE-2026-114074 or the next vulnerability affects your stack