What’s Vulnerable › Vulnerabilities
CVE-2026-114077: Trigger.dev before 4.5.6 Cross-Tenant Deployment Hijack via createDeploymentBackgroundWorkerV4
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-22
- Weakness: CWE-639
Description
Trigger.dev before 4.5.6 contains an authorization bypass vulnerability in createDeploymentBackgroundWorkerV4 that resolves a WorkerDeployment by friendlyId alone, without environment, project, or organization scoping. Attackers holding only their own environment API key can POST to the deployment background-workers endpoint with a victim's deployment ID to re-point that in-progress deployment at a worker in the attacker's environment.
Affected products
- triggerdotdev trigger.dev: before 4.5.6 — fixed in 4.5.6
How to fix
Upgrade to a fixed version: triggerdotdev trigger.dev 4.5.6. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-2gvw-9968-v578
- https://www.vulncheck.com/advisories/trigger-dev-before-4.5.6-cross-tenant-deployment-hijack-via-createdeploymentbackgroundworkerv4
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-2gvw-9968-v578
Get alerted when CVE-2026-114077 or the next vulnerability affects your stack