What’s Vulnerable › Vulnerabilities
CVE-2026-114079: Trigger.dev before 4.5.6 Cross-Environment Deployment Cancel via Cancel Endpoint
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-639
Description
Trigger.dev before 4.5.6 contains an improper authorization vulnerability that allows holders of lower-trust environment API keys to cancel other environments' deployments because DeploymentService.getDeployment scopes lookups by projectId only. Attackers with a dev, preview, or CI secret key can POST to the deployment cancel endpoint to cancel in-progress production deployments within the same project.
Affected products
- Npm Trigger.Dev: before 4.5.6 — fixed in 4.5.6
- triggerdotdev trigger.dev: before 4.5.6 — fixed in 4.5.6
How to fix
Upgrade to a fixed version: Npm Trigger.Dev 4.5.6; triggerdotdev trigger.dev 4.5.6. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-4672-hwv6-gq62
- https://www.vulncheck.com/advisories/trigger-dev-before-4.5.6-cross-environment-deployment-cancel-via-cancel-endpoint
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-4672-hwv6-gq62
Get alerted when CVE-2026-114079 or the next vulnerability affects your stack