What’s Vulnerable › Vulnerabilities
CVE-2026-114082: Trigger.dev before 4.6.2 Overly Broad Realtime Session Stream Credentials
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-22
- Weakness: CWE-862
Description
Trigger.dev before 4.6.2 contains an authorization vulnerability that allows public-token holders with session write access to obtain environment-wide S2 stream credentials via session input initialization. Attackers can use the credential directly against the storage API to append, create, or trim other session and run streams, forging output or permanently deleting records.
Affected products
- triggerdotdev trigger.dev: before 4.6.2 — fixed in 4.6.2
How to fix
Upgrade to a fixed version: triggerdotdev trigger.dev 4.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-cpx8-cffg-mp4w
- https://www.vulncheck.com/advisories/trigger-dev-before-4.6.2-overly-broad-realtime-session-stream-credentials
Get alerted when CVE-2026-114082 or the next vulnerability affects your stack