What’s Vulnerable › Vulnerabilities
CVE-2026-114083: Trigger.dev before 4.5.0-rc.3 Path Traversal via Packets Presigned URL Endpoints
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-27
- Weakness: CWE-22
Description
Trigger.dev before 4.5.0-rc.3 contains a path traversal vulnerability in the api/v1/packets and api/v2/packets endpoints that allows authenticated tenants to escape their object key prefix through an unsanitized filename splat segment. Attackers holding one valid API key can supply ../ sequences to obtain presigned GET or PUT URLs and read or overwrite other tenants' run payloads and outputs.
Affected products
- triggerdotdev trigger.dev: before 4.5.0-rc.3 — fixed in 4.5.0-rc.3
How to fix
Upgrade to a fixed version: triggerdotdev trigger.dev 4.5.0-rc.3. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-gx7f-q62h-9fxp
- https://www.vulncheck.com/advisories/trigger-dev-before-4.5.0-rc.3-path-traversal-via-packets-presigned-url-endpoints
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-gx7f-q62h-9fxp
Get alerted when CVE-2026-114083 or the next vulnerability affects your stack